Aggiornare PHP da 5.1.6 a 5.2.4 e successivi (testato su VPS Aruba)

Primo passaggio. FARE IL BACKUP, molto importante.

Prima di agire vi consiglio di leggere tutti, fino in fondo!!!

Per aggiornare un server CentOs (come quelli di Aruba) a PHP 5.2.xx la prima prova che possiamo fare è:
# yum update php
Risultato:
Il tuo PHP è già aggiornato. Questo è dovuto al fatto che CentOs lavora con pacchetti STABILI e TESTATI.

Se a noi ci dovesse servire un PHP più aggiornato (ad esempio per WordPress 3.2) la soluzione più semplice è quella che vi propongo in queste poche righe.

Riconoscere la firma
rpm --import http://www.jasonlitka.com/media/RPM-GPG-KEY-jlitka
La seguente solo per CentOs 5
rpm --import http://mirror.centos.org/centos/RPM-GPG-KEY-CentOS-5

Abilitare Jason’s Utter Ramblings Repo (solo per CentOs 4)
yum utterramblings http://www.jasonlitka.com/media/EL4/$ARCH

Crea un nuovo file con le indicazioni del repository
nano -w /etc/yum.repos.d/utterramblings.repo

Aggiungere le seguenti righe di codice:

[utterramblings]
name=Jason's Utter Ramblings Repo
baseurl=http://www.jasonlitka.com/media/EL$releasever/$basearch/
enabled=1
gpgcheck=1
gpgkey=http://www.jasonlitka.com/media/RPM-GPG-KEY-jlitka

Attivare il repository e aggiornare php
yum update php
e proseguire con l’aggiornamento.

A questo punto mi si è bloccato tutto (le installazioni di wordpress non comunicavano più con il DB).
MySql non riesce più a partire.

Lancio
yum update
e faccio fare un aggiornamento completo.

Nulla… non parte nulla… QUINDI PER ORA IO CONSIGLIO DI NON FARE QUESTO UPGRADE COSI’… L’avevate fatto il backup, vero?

Il tutto è stato preso in rete da:
http://www.freshblurbs.com/install-php-5-2-centos-5-2-using-yum
http://www.jasonlitka.com/yum-repository/

Volete invece aggiornare Realmente PHP e/o MySQL?
Ecco l’articolo che fa per voi!

Vuoi fare l’aggiornamento a PHP 5.4??? Ecco qua un nuovo articolo

Aggiornare PHP da 5.3 a 5.4 su server CentOS 6.7 su Aruba

Commenti

commenti

Powered by Facebook Comments

2 thoughts on “Aggiornare PHP da 5.1.6 a 5.2.4 e successivi (testato su VPS Aruba)

  1. Su diversi forum ho letto che per evitare il problema della connessione bisogna iniziare l’update proprio da Mysql ed in automatico viene aggiornata anche la versione di PHP.
    In effetti io sono riuscito ad aggiornare tutto (uso un VPS linux di Aruba con sopra diversi siti in WP).
    L’unico problema riscontrato è un utilizzo anomalo della CPU quando viene interrogato il Db (tipo quando viene richiamata la pagina “archivi” di wordpress) che porta il VPS al blocco.
    Sto ancora cercando di capire il motivo.

    saluti

Comments are closed.