Aggiornare VPS a PHP più nuovo (testato su VPS CentOs Aruba con PHP 5.3.6)

http://www.atomicorp.com/wiki/index.php/PHP#Installation
http://en.ispdoc.com/index.php/Updating_PHP_in_CentOS_Linux

wget -q -O - http://www.atomicorp.com/installers/atomic | sh
(c'è un ulteriore passaggio da eseguire ma solo in alcuni casi, guardate l'errore in fondo)
yum update php



Ora è aggiornato, ma WordPress da questo errore:

Error establishing a database connection

Quindi

mysql_upgrade

e non funziona

vedendo il log diceva:
/usr/libexec/mysqld: unknown option ‘–skip-bdb’

quindi si modifica il file
/etc/my.cnf

nano /etc/my.cnf



[se nano non dovesse essere installato è possibile installarlo con:

yum install nano



oppure si può usare qualsiasi altro editor.]

aggiungedo il cancelletto davanti alla riga in questione:
# skip-bdb

service mysqld restart



e FUNZIONA!

Per sicurezza ho lanciato anche un aggiornamento del DB

mysql_upgrade -u admin -p



e poi richiede la password dell’utente.
e per completare il tutto ci vuole un reboot dei servizi apache

service httpd restart



Risultato:
php -v
PHP 5.3.6

 

AGGIORNAMENTO PER SERVER VPS CON ERRORE php-common – php-ncurses
Error: Missing Dependency: php-common = 5.2.17-1.el5.art is needed by package php-ncurses
Nel caso riceviate questo errore la cosa più semplice da fare è TOGLIERE php-ncurses
yum remove php-ncurses -y


poi potete fare
yum update

Volete invece aggiornare con YUM su CentOS e Plesk?
Ecco l’articolo che fa per voi!

Commenti

commenti

Powered by Facebook Comments

8 thoughts on “Aggiornare VPS a PHP più nuovo (testato su VPS CentOs Aruba con PHP 5.3.6)

  1. Pingback: Aggiornare PHP da 5.1.6 a 5.2.4 e successivi (testato su VPS Aruba) | manulele.it

  2. Pingback: SSH e installazione Yum su CentOs – Plesk Server | manulele.it

  3. Pingback: Ripristino accesso e connessione Plesk e MySql e cambio di password (test su VPS Aruba) | manulele.it

  4. Dopo tentativi senza successo, ho trovato questo post…

    Fantastico, grazie: tutto risolto ed aggiornato con plesk funzionante…

  5. Pingback: Aggiornamento PHP su VPS Aruba - Pagina 8

Comments are closed.